Can't Connect to Altis

I’ve been playing on the Altis server for a while now but recently I’ve been unable to connect to it at all, I can connect to the Apex server perfectly fine but prefer Altis because my friends don’t have Apex. We do use mods and I tried joining without any mods and that didn’t work, also tried using a different internet and had no success there either. I’m a bit stumped on what’s causing me not to connect to the server and was wondering if anyone here may know why I can’t connect to Altis specifically?

We would need more information to help you.

What happens when you try to connect?
Do you get any type of error?
If you can attach your RTP file that would help.
To find your RPT file, make sure to show hidden files and folders.
From the File Explorer address bar type %localappdata%/Arma 3
Locate the file with the RTP extension with a date range for when you tried to connect.
Attach the RTP file to the forum post

or Connect to TeamSpeak and request help from an admin by joining a help room.