Help - Can't find NAK servers!

Am at my wit’s end here. Maybe someone recognizes my problem. My Arma launcher cannot locate any NAK servers, except on rare occasions. I have marked the four NAK servers as favorites numerous times in the past. Very occasionally one of the servers will pop up in the launcher but there’s no logic here. If I use the “recent” tab, mostly I get nothing, even if I have just been in-game on one of the servers. Or one of the servers I haven’t played on recently will pop up. Whenever the launcher does find a server (almost never) it always pops up with the favorite star selected, so somehow the game remembers my favorites. I have resorted to doing the web search using the “NAK” parameter multiple times. I can wade through 500 servers without any NAK servers being discovered.

In the last week the only way I can get onto any server is by entering the IP address. Even that is very iffy. I usually get cycled through the main and sub-main launcher windows a few times and have to enter the IP several times to get on. Oftentimes I can’t get on at all, even after multiple tries. I recently made the dreaded changeover to Win 10 and did a complete new install of Steam and Arma. I have since run the file validation function several times, and just now re-installed Steam again to see if that had any effect. It didn’t. I actually got onto Malden this afternoon and played about a half hour before the afternoon reset, then completely failed to get in again after the reset - using ANY method.

What happens most often when I think the launcher is going to work is that it indicates that Arma and Battleeye are loading. I get to the Arma loading screen - the one with the gray, lined background, and it just stalls there. That’s when I back out out of frustration and try to get on using the IP address, which is failing as often as it succeeds now. I am wondering if there could be some routing issues between my location in the West, and the NAK servers, but if that were the case I wouldn’t expect to even get the beginning of the Arma loading screens. I would like to blame Win 10, but the fact that I do occasionally succeed in logging on would seem to indicate that isn’t the case. I have updated and re-loaded everything I can think of but nothing seems to work - and , in fact, things seem to be getting worse. Any help would be appreciated.

It sounds as if your router or firewall is blocking the ports need for Arma. To make sure you can connect you need to make sure port 2302-2307 TCP and UDP, 2402-2407 TCP and UDP. You will also want to make sure both the Arma program and Launcher are whitelisted in your firewall.

For configuring your router you will need to refer to your router’s documentation.
If you use Windows Defender you can refer to this document for allowing Arma and the launcher in your firewall. -

Thanks Vile. Windows Defender is showing all Steam and Arma references as “allowed.” However, there were no specific ports listed.I am experimenting with adding specific port numbers. This must be only in reference to Win 10. Win 7 never required it.

Right after you manage to see the servers, see if you are able to keep it on Favourites. After you confirm the firewall.

But as Vile stated, the recent windows update, fiddled with the firewall.

Others have been having same faults:

“Happen to me since last windows update. Check firewall and allow both outbound and inbound connection for arma then problem solved for me. Maybe you should give it a try.”

“Right mod versions? Right client version? Missing mods? Online on steam? Battleye working? Another problem could be that the server has a high ping for you and your requests time out so check that aswell.”

“Yes, it is a problem with the development build, which basicly sucks if you want to play multiplayer. I regret I’ve bought it.”

“I had this same problem and when i started the launcher it said battleye couldnt be updated bacuse the server couldn’t be reached so eventually i thought to manually update battleye and it worked”

I can’t even say “hope that narrows things down” as it’s pretty much anything and everything. Goodluck any how.

I have pretty much thought about most of those things, though I haven’t had occasion for having to deal with most of them - this since the days of the Commodore 64. Win 10 has been a paradigm shift for me. I have always maintained separate drives for operating system, programs, and files. When I moved to Win 10 I quickly discovered that some of the latest programs I had to Install didn’t even offer an option for installation anywhere but “C” drive. For a couple years now I have been using SSDs for OS and programs - keeping hard drives only for files and backups. Win 10 forced me to go with a large M2 where I now mix the OS and all program installs. I am having difficulty accepting the increasingly dumbed down systems being fed to us these days. I suppose the good side is that it”s forcing me to get under the hood in places I’ve never had to to before.

UPDATE: With all references to Steam and Arma showing as allowed in my firewall, and even after having created new inbound rules for ports 23 and 2402 (firewall indicates all outbound ports are allowed), my Arma launcher is still pretty much crippled. Behavior is very erratic. Internet searches with a NAK filter, of over 600 servers still don’t find the NAK servers. I go back and forth between the FAVORITES and RECENT tabs. sometimes one or two servers will pop up. Mostly they bring up nothing. Tonight I managed to bring up both Malden and Altis under FAVORITES. Switched to the RECENT tab (nothing there) and immediately switched back to the FAVORITES again and only one of the two that were just there now appeared. No consistency. No repeatable behavior that can be noted. The only server I could bring up this afternoon, using ANY method was Altis, where I played briefly. If anybody comes up with solutions for this situation I would certainly like to hear them!