Little help with mods

So until today the only mods i was running were the ones i got off the malden and synthesis servers and no weapon sway. I went on a hunt for some mods like a javelin mod, advanced ally map info feed, enhanced movement BUT when i try to use any mod aside from what was loaded from joining nak servers i am stuck in the loading screen after selecting your slot… not sure what to do here… i deleted all the mission files so it had to download new when joining, restarted my pc, made sure nothing was set to read only… cannot figure out why i keep getting stuck on that loading screen. It really is ANY other mod too, i went through trying to connect with each one selected one by one and the only one it will let me past that screen is if im only running no weapon sway.

never mind its happening even without the mods… idk…

Are you sure you deleted the mission files correctly. Other than that it could be the TCP-UDP ports not open, a new firewall entry, your ISP blocking traffic etc.

nah gotta be game/mod related. The issue didn’t occur until about 90 mins ago when i started trying to get mods. before that my connection has always been flawless. I don’t even get much lag in game and i keep my vis about 8000. Issue is replicable across all nak servers (didn’t spend much time checking any other servers as by that time i was quite annoyed as i just had to format my hdd bc of that stupid battleeye not responding thing, absolutely only way to fix it when i have that issue, none of the recommended fixes work) as for the mission files that are downloaded from the server that ones easy, if it downloads it then you deleted it lol. I’m currently awaiting a reinstall.

I do know of one mod that will do that every time and thats Zehn’s advanced gps and rangefinder… really cool mod, you can look in the rangefinders and mark a spot on the map instead of guessing, others who don’t have the mod can’t see it but you can use it to place a marker that others can see. I only got to use it a few times about 3-4 years back but now on any server it causes the load screen bug. for all i know it could have been the culprit. even though i removed it lol. Won’t know for sure even after the reinstall but as long as it works again ill be happy lol.

Currently that is not an approved mod on the server, To submit it for approval submit a mod request -

Please make sure to check your mods against our current official mod list . Any mod not list as approved is not “allowed” and can get you kicked or banned. For any mod not on the list that you would like to use, submit a mod request and we will review it.

oh no point lol its been abandoned for some time, i was hoping after some arma updates it would start working again… it was so cool lol

I didn’t know that about the approved mods tho, i’ll have a look.

Ok time for technical assistance. I am now running only approved mods. I have reinstalled arma, deleted all user profiles, I am behind no firewalls, my ping is excellent. I get sound, but the loading screen is still in the way. I dunno what to do at this point.

Did you delete the mission cache :

"%localappdata%/Arma 3/MPMissionsCache"

and delete all files.

ok idk why but this worked: went into game and deleted all profiles but the main one, then recreated. Somehow that fixed it… before to delete the profiles i deleted the folders.

The launcher update that happened on the 24th has caused problems with many players

OOooOO could be it… i was perfectly fine outside of battleye issues… but then i just had to go and play with mods hahaha