Map causes ctd

Idk why but every like 50th time i open the map it causes arma to crash. Doesn’t matter how long im in the server either. it’s the weirdest thing. Like JUST now i was in there, opened map ONCE it crashed lol. Now watch ill play for like 4 hours with no crash lol… what is up with that? lol

ArmaReport_Log_20190517T183355_Steve.zip (27.9 MB)
this is the bug report if it helps

Still testing my theory but i believe this was caused by changing keybinds. Somewhere along the way gps got changed from left crtl+m to Right ctrl+m i didn’t know and changed the key to just m and map to lcrtl+m , since setting everything back to default it hasn’t happened again. I have ABSOLUTELY no idea why that would cause that but like i said i could be wrong still testing. I also lock up a bit getting in and out of vehicles.

Pretty sure thats what it was, game hasn’t ctd since i fixed the keybinds. Also slight momentary lock up getting in and out of vehicles was caused by view distance not being the same in the vehicle as outside the vehicle. setting them all to the exact same values fixed that.

nope, its not the keybinds. just crashed opening the map.

There are many causes for your issue. First create a new profile, your profile may be corrupt. Next in File Explorer, in the address bar type “%localappdata%/Arma 3/MPMissionsCache” without quotes. Delete all files in this directory. This will force Arma to re-download the mission files when you connect to a server again. The only negative of deleting all files is you may have to re-download a mission file again that did not need to be updated, which should take around 30 seconds.

Last is a memory issue, which is much harder to fix. The first thing would be to disable absolutely everything that does not need to be running in the background. And rebuild your page file. There are tutorials online about how to do this, but in general set your page file to 0 on all drives, Defrag your appropriate drives, non SSD. Restart your computer and reset a proper page file, then restart again.

I recommend that you do each step and test before going on to the next. The steps are progressively less likely to resolve the issue, and more complicated.

Let me know if this does not help

Will do, thankfully I know how to do all of that lol on the memory note while i do only have 8gb gddr5 (or 3 i don’t remember anymore and speccy only shows it as 8gb single channel unknown lol) even with arma running im only at about 75% of it. Graphics card has 2gb gddr3, in the monitor it shows i only use about 75% of that… however even tho all testing shows my hdd is fine i think its starting to die if that could cause that. i only mention it bc you said about the page file which of coarse is hosted on the same ssd drive. I ran like 3 different diagnostic programs on top of the built in boot check from the mobo everything says its fine… unless its windows messing things up. it’s so hard to pinpoint things unless you got something that will tell you exactly where the issue is lol. I’ve also thought about this. my net isn’t that great… when i open the map (and it doesn’t crash obv) it does take a while to update where the missions and such are. The basic altis map loads instantly… just the dynamic stuff can take a while to load. Unsure how network might cause the game to crash like that but those are the theories i have lol all of which i have no conclusive evidence of haha

So far so good, i just did em all. only took like 10 mins. but then yesterday i played for hours thinking i had fixed the issue lol so no way to know until at least a good day or two passes lol

Ok so no, the issue remains. Always kicks out the same error but from what i’ve read it such a wide array of possible causes the error code doesn’t really help with is status_access_violation 0x0c0000005

A couple more things. Unsubscribe and resubscribe to all the Wasteland mods and second make sure that something did not change your profiles folder to read-only. It is not likely to be a network error, but Wastelands does send a lot more information back and forth over the network than Invade and Annex.

Other than that, I really do not know. You can run some performance monitors (CPU, Memory, Disk Read/Write, PageFile) locally to see if a certain condition happens when it crashes.

been trying to check windows event logs too the only thing in there is a dcom error which according to the internet is a benign issue well known to effect everyone.

the profile folder was indeed set to read only… huh

That can do it.

so far over the last 4 hours or so ive had no issues… hopefully it will stay like that lol

Ok i’m pretty confident the issue has been resolved. Thank you vile for the suggestions… crazy that something as simple as read only on the profile folder causing the issue lol

So after yet another clean reinstall of windows and it was still happening i went to the bi forums… winds up a few ppl are affected by this after the recent update. Just figured i’d give an update.