My ARMA is borked

Sent this to Bohemia today;

Hello and thank you for your time.

I am having an issue with ARMA III either crashing when loading a multi-play server or crashing shortly (2-3 min) after joining a server. The error I reccived was - 0xC0000005 - ACCESS_VIOLATION.

I reffered to the FAQ on the Bohemia WIKI but have had no luck thus far.

So far my attempts at solving the issue have included;

  • Joined another server, then rejoined the previous one.
  • Updated the graphics card drivers to a newer version.
  • Checked the temperature of my GPUs and CPUs (well in the green.)
  • Verified the integrity of the game cache using Steam.
  • Re-installed DirectX.
  • Uninstalled the Visual C++ 2013 Redistributable package (both x86 and x64 version), restarted my computer and installed the package again.
  • Ran a Windows System File Check tool to repair corrupted system files.
  • Uninstalled all mods for ARMA III.
  • Uninstalled ARMA III, restarted my computer and reinstalled.

My connection and system specs are well within the requirements for ARMA III and I have been playing the game for the last year or more on the same system. I have updated anti-virus and ARMA III is listed as an exception to both my anti-virus and firewall. ARMA III is the only game I have had issues with recently. DayZ seems to be running fine and I consider that to be as close to a benchmark for ARMA III that I can get. The issue only started a few weeks ago and has been progressive. For awhile I could play after crashing once or twice, but now it crashes without fail every time.

If you could provide any assistance it would be much appreciated. I have included the crash log and am willing to provide any further information you might need in order to assist me.

Thanks again!

Hopefully I get a helpful and timely response.

If anyone has any further suggestions let me have it!

Just increase your page file
link how: How to Change the Windows Pagefile Size - MCCI

Thanks for the idea Claws!

Gave it a shot, and I cleared up a bunch of space on my SSD. Sadly though, no dice, same error.

I’ll try hacking at it again tomorrow.

Got a response from Bohemia;


please try clean reinstallation of Arma 3:

  1. Uninstall the game.
  2. Download and install CCleaner (> Speed up, optimize and clean your PC for free | CCleaner for PC> ) and
    scan/fix your registry.
  3. Make a backup of Arma 3 folder in Documents.
  4. Delete both Arma 3 folders in Documents and Steam:

\Users*YOUR USERNAME*\Documents\Arma 3

\Program Files (x86)\Steam\SteamApps\common\Arma 3

  1. Reboot your PC.
  2. Run Steam as Admin, download the game.
  3. Try to run Arma 3 (without mods).

This should fix your issue.

I went through the list and did everything, loaded up NAK #1, then crashed out with the same error code within 3 minutes. Attempted to use an official server. Played for almost 30 min before crashing with the same error.

I just wanna play the damn game.

Found an old tweak post (2015) to try and fix the issue (in addition to everything else I have tried.)

so after a little bit of tweaking today i have figured that this setup for the launcher is working for me. nonstop 2hrs of play and no crashes, i am using the 1.48 RC build… but let me say before the tweak i was having problems on the 1.48 RC build too…


“enabling the malloc: system is a big one, helps with most crashes.”

Screenshot by Lightshot

Played on Tanoa for over an hour after applying that. I’ll test it out more tomorrow but might be a fix.

The bright side of this is I really cleaned up my system which honestly needed to be done.

The last message you posted was the case at one point, but somewhere around the Jets DLC BI fixed it so you no longer needed to set CPU Cores or change the Memory allocator. If it fixes your problem, I’m happy for you, but if not, there are many other things to try.

If your issue is not resolved poke me in Teamspeak and we can see if I can give you some directions to resolve the issue.

Seems to not be the cores but the malloc: system that fixed it. Dunno why or how. Since changing it I have had 0 crashes though.