Support for TFC-CAF Pack

The TFC pack or Task Force Canada pack is basically already supported by the server specifically the NAK #1 Altis CooP server, however, there seems to be an issue where after you shoot any of the sniper rifles from the pack be it the C14 or C15 you can’t shoot again until you reload, removing other mods as well as testing on different servers it seems to be a server-side issue. I super love the C14 and 15 and being able to properly use them in-game without needing to reload after every shot would be amazing. :smiley:

Basically the issue is after making your first shot, your character bolts the next round but when you click fire instead of shooting he just “tries” to bolt another round, again tested outside the server and I’ve already contacted the mod devs on their discord it seems to be server-side. Any help or asap response would be greatly appreciated, definitely one of my favorite servers! <3

We have no scripts that would affect this mod.

Strange cause it only has an issue on this server. I’ll have to try some other servers maybe something my setup is causing this issue. The mod devs were unable to replicate it.

I think one of the problems is, that the mod isn’t even supported yet.
I neither see it on the approved list or in the mod request forum.
I tested the mod in SP and it seems like it’s WIP.
You can’t add magazines to the C15, but the C14 worked fine for me.
I tried the C14 on the server with the default CBA settings.
After playing around, I found out that changing from the default CBA Weapons weapon repetition mode “Leave Optics View” you can at least shoot from your shoulder in 3rd Person.
You can change that setting in Options/Addon Options/CBA Weapons
I don’t know how you would solve the general problem and what the exact problem is.

Richard Weiss

I’ve also tested some bolt action rifles from other mods and found out that all CUP Weapons Bolt action rifles have the same problem.
Meanwhile you can switch to the RHS bolt action, they worked fine.